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Cindex 2.0 for Windows
This document explains how Cindex™ 2.0 for Windows differs from Cin-
dex™ 1.5 for Windows.

You should read this document if you are upgrading from Cindex 1.5 for 
Windows. You do not need to read this document if you are a new user of 
Cindex.

Cindex 2.0 for Windows works very much like Cindex 1.5 for Windows. If 
you are familiar with Cindex 1.5 for Windows you should have no diffi-
culty mastering Cindex 2.0.

Overview of New Features

User Experience and 
Productivity

Cindex provides greater flexibility in working with indexes. You can more 
easily move around in the main view of the index, particularly while you 
are editing entries. There is a new optional interface for record entry, and 
major new editing capabilities including unlimited undo and redo, an 
exceptional ‘smart’ flip, and better checks for well-formed entries.

Cindex provides new checks for entries that use too many unqualified 
locators, and for orphaned subheadings. When See cross-references refer to 
fewer than a specified minimum number of target entries, Cindex can 
automatically convert them to fully-qualified entries.

Managing Index Files Cindex routinely checks the integrity of indexes, and can repair records if 
they are ever damaged. A new revert-to-saved command restores the index 
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to its last-saved state—useful if you have made some major changes to the 
index that you then decide to discard. 

Managing Multi-Purpose 
Indexes

An index record can now contain a special field for holding a comment or a 
web address, etc. You can use multiple labels to control the visibility of dif-
ferent kinds of index records. 

Searching You can now search for records made or edited by a particular user. You 
can exclude from searches records that have specified attributes.

Formatting Entries Headings and subheadings can be preceded by optional prefix text. You 
can override the standard index style on an entry-by-entry basis. There are 
new options for placing cross-references and for punctuating them auto-
matically.

Sorting Entries New capabilities include better handling of text in parentheses, preset 
options for Chicago Manual of Style or ISO 999 alphabetizing, and more 
refined sorting of locators.

Exporting Entries Cindex can now export a fully formatted index as tagged text for Adobe 
InDesign. When you embed entries in other documents you can now con-
trol whether sorting information is also embedded.

Help There is new and richer on-line help. Cindex can notify you automatically 
when an update is available.

System Requirements

Cindex 2.0 works with Windows XP SP2 or higher. It will not run under 
any earlier version of Windows.
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Compatibility

Cindex 2.0 can work with all documents made by earlier versions of Cin-
dex for Windows. Documents made by Cindex 2.0 are interchangeable 
with documents made by Cindex 1.5, with the following exceptions:

• Index files
• Index templates
• Index group files

When Cindex 2.0 opens an index or an index template made by an earlier 
version it will convert the index or template to a new format. It will also 
remove any groups that belong to the index. After conversion you will not 
be able to open the index or template with an earlier version of Cindex. 
Cindex will warn you before converting an index.

If you need to provide someone with an index that will work with Cindex 
1.5, save it as an archive.

Document Management

Cindex checks the integrity of an index each time the index is opened. If 
Cindex detects any errors or damage, it will alert you and recommend that 
you let it repair the index.

Cindex now provides a Revert to Saved command in the File menu. This 
restores the index to its last-saved state. You might wish to do this if you 
have made some major changes to the index that you then decide to dis-
card. Cindex updates the saved copy automatically at regular intervals if 
you have specified this via Preferences…. Cindex also updates the saved 
copy when you choose Save from the File menu.

Archives When you open an archive (either with Open… or by double-clicking it), 
Cindex no longer automatically asks you if you want to make a new index 
or include records in an existing index. If no index with the name of the 
archive exists in the folder containing the archive, Cindex will automati-
cally create an index of that name and read the archived entries into it. If an 
    3



                                                          
index with the name of the archive already exists, Cindex will prompt you 
for the name of a new one.

To import records from an archive into an existing index, choose Import… 
from the File menu.

Use Dictionaries and 
User-Defined Tag Sets

Cindex now keeps user dictionaries and user-defined tag sets in a private 
folder unique to each user. Sets of markup tags provided with Cindex are 
distinguished from user-defined tags sets by having names that begin with 
$ (e.g., $AAP, $UCP). When you install Cindex it automatically copies your 
existing user dictionaries and tags sets to this private folder.

Exporting Documents Cindex can now export formatted indexes as tagged text documents for 
Adobe InDesign.

Commands

New Commands There are four new commands:

• A Revert to Saved command in the File menu. See “Document Manage-
ment” on page 3.

• A Redo command in the Edit menu. See “New Editing Capabilities” on 
page 7.

• A Hide by Attributes command in the View menu. See “Viewing the Index” 
on page 8.

• A Check for Updates command in the Help menu.

Commands Moved The following commands have been moved:

• New Group and Save Group… are now in the File menu.
• Abbreviations… is now in the Tools menu. The associated Sort by Expansion 

command has been removed (its function is handled by Abbreviations…).
• Spelling… (formerly Check Spelling…) is now in the Edit menu.
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Commands Changed Duplicate (Edit menu) has a new keyboard shortcut: CONTROL SHIFT Y. The old 
shortcut (CONTROL Y) is assigned to the new Redo command.

The Labeled command (Edit menu) now contains a submenu that provides 
additional labeling options. See “Record Attributes and Structure” on 
page 6.

Verify Cross-References… (Tools menu) has been extended and renamed Check Ref-
erences… See “Checking References” on page 11.

Generate Cross-References… (Tools menu) has been extended and renamed Man-
age Cross-References…See “Managing Cross-References” on page 11.

Toolbars Buttons in the main toolbar for Alphabetical and Page Order sorting now 
have keyboard shortcuts (respectively, CTRL SHIFT A and CTRL SHIFT L).

Toolbar buttons for flipping record fields have changed functions. See 
“New Editing Capabilities” on page 7.

General Settings

Several new settings made via Preferences… (under the General tab) provide 
you more flexible control of Cindex:

• You can specify the action to be taken when Cindex starts: open the last-
used index, display the Open panel, or do nothing.

• You can set the user identifier independently of whether you wish to be 
prompted to enter it on startup.

• You can specify the number (between 4 and 10) of recently-used index 
documents whose names Cindex will display in the File menu.

• You can set Cindex so that it automatically notifies you if an update is 
available. (You can also check for updates at any time by choosing Check 
for Updates from the Help menu).
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Record Attributes and Structure

A record may now have one of seven different labels, identified by text dis-
played in a distinctive color. To accommodate this change, the Labeled com-
mand now exposes a submenu, and the Label toolbar button now carries a 
drop-down list. There are corresponding changes in the Find and Replace 
panels, so that you can search for records that have a specified label. 
Expanded Preferences… settings (under the View tab) allow you to assign a 
different color to each label. The keyboard shortcut formerly used for label-
ing and unlabeling records (CONTROL L) works, as before, to apply and 
remove Label 1 only. The shortcut is not visible as a menu item, and has no 
effect on records that carry other labels.

You can now specify (via Record Structure in the Document menu) that a 
record must always contain a special subheading field that you can use to 
store a comment or a URL, etc. At your option Cindex can ignore this field 
when sorting records and can hide it when it displays a formatted index. 
This special field, when present, is always the one immediately preceding 
the locator field.

In an index that already contains records you can now change (via Record 
Structure in the Document menu) the minimum number of record fields.

There is a new setting under Reference Syntax… (Document menu) to control 
whether Cindex recognizes cross-references entered as subheadings. The 
default (for new indexes) is to recognize cross-references only in the locator 
field.

Adding and Editing Records

Cindex provides a new interface for adding and editing records. When you 
add or edit a record, Cindex opens up an entry window contained within, 
and at the bottom of, the main view window. This removes clutter from the 
screen.You can size the entry window by dragging the bar at its top. Cin-
dex remembers the last-used size.
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If you prefer to use the old interface, in which records are entered in a sep-
arate window, you can specify this via a new Preferences… setting (Use Separate 
Window under the Editing tab).

While using either the new-style or old-style record entry widow you can 
move around freely in the main index view and select records for editing. 
When the record-entry window is open Cindex directs all keystrokes to 
that window or to the main view window, depending on which is active. 
To activate an inactive window, click it or hit CONTROL-TAB.

Several commands (e.g., Find, Check References, Count Records, Index Statistics) that 
were formerly disabled when the record-entry window was open can now 
be used when it is open.

Changed use of ESC key Hitting ESC now always closes the record-editing window and discards any 
changes to the record. To close the window and save changes, hit CONTROL-
RETURN, or ENTER on numeric keypad.

New Editing Capabilities The editor used when you make and modify records is improved:

• It provides unlimited undo, and corresponding redo of previous undo 
actions.

• If you have enabled auto completion (via Preferences… in the Edit menu) 
and Cindex has suggested a completion, you can hit RETURN to accept 
the selected text and open up a new record field. In any other context 
hitting RETURN behaves as before: it removes the selected text then 
opens up the field.

• If you hold down the SHIFT key while you paste or drag text into the 
record window, Cindex will insert only plain text (discarding informa-
tion about style and font).

• In addition to the warnings Cindex provides for mismatched {…} and 
(…), Cindex will warn you when you enter mismatched "…" or mis-
matched smart quotes (“…”).

• You can half-flip (promote) a subheading to a heading (discarding the 
heading at the level above). The shortcut for a half-flip (CTRL –) is the 
one previously used to flip headings without changing the case of initial 
letters. 
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A flip can be 'smart' at the user's option. In a smart flip Cindex adjusts 
the case of leading letters, and moves prepositions and articles, or the 
prefatory text to see also cross-references, if necessary. A new Preferences… 
setting (Editing tab) determines whether Cindex executes smart flips.

• When you attempt to enter a record that is incomplete or badly con-
structed (e.g., contains mismatched angle brackets <…>), Cindex now 
displays information about the error in the status bar at the foot of the 
entry window.

• When you use a hot key to insert text in a particular font or style, Cin-
dex no longer carries the style and font of the inserted text to characters 
you subsequently type.

Viewing the Index

The main window now provides smooth scrolling in both vertical and hor-
izontal directions, with mouse wheel support. When a record is selected, 
you can extend the selection via the keyboard by holding the SHIFT key 
down while hitting the UP-ARROW or DOWN-ARROW key.

Because a record can now carry one of seven different labels there is a 
change in the way Cindex uses color to identify a labeled record in the fully 
formatted view of the index. Only the locators (page references or cross-
references) that belong to the labeled record are colored, unless the locator 
field has no text, in which case the last visible subheading is colored.

You can use labels to control the visibility or records. The new menu com-
mand Hide by Attribute… allows you to hide records containing particular 
labels (or none). Records that are hidden are invisible to all commands that 
act globally on the index, except Compress and Expand, which ignore the Hide by 
Attribute… setting.

Find, Replace, and Spelling

The Find, Replace and Spelling windows contain a new button (Reset) that 
replaces the former Cancel/Stop button. Reset clears the existing search set-
tings and restores them to the default. The keyboard command to close any 
of these windows is ESCAPE.
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When you are working with a fully formatted view of the index, Find, Replace 
and Spelling are sensitive to the setting of Hide by Attribute….

You can use Find to search among records when the record-entry window is 
open.

With Find you can search for records made or modified by a particular user.

When you use Find or Replace to search for locators within a specified range 
and your locators are multi-part references, you can omit from the search 
specification any part of the specification that is common to both parts. For 
example, you could enter the full range specification 23A66-23A69 as 
23A66-69.

Find and Replace provide new options for searching among records with spec-
ified attributes:

• As in earlier versions of Cindex, you can confine a search to records that 
have particular attributes (New, Modified, Deleted, etc.), but you can 
now also confine a search to records that lack particular attributes.

• When you specify that the search involves labeled records you can now 
specify a particular label.

User dictionaries for Spelling can now hold many more entries (~6,600).

Formatting Entries

In the fully formatted view Cindex can now provide prefix text immedi-
ately before the text of any level of heading. Set this via Headings… in the 
Document menu.

In a fully formatted index that is displayed indented, you can override the 
default layout of individual entries by including special text in records. If 
the last character of any heading or subheading is a vertical bar (|), Cindex 
will run-on all lower levels of heading for that entry. Cindex automatically 
substitutes the appropriate leading punctuation for the bar as it formats 
the entry.

Cindex provides (via Cross-References… in the Document menu) new options 
for placing and punctuating cross-references:
    9



• Cindex can place see also references after all subheadings, except when 
there are no subheadings, in which case the cross-references directly fol-
low the page references from the heading.

• Cindex can now automatically capitalize the first word of the prefatory 
phrase (e.g., "see…" or "See…") according to the placement and punctu-
ation of the cross-reference.

Exporting Formatted 
Entries

Cindex can now export a fully formatted index as tagged text for Adobe 
InDesign.

Cindex now provides a richer export for QuarkXPress tagged text, includ-
ing information about extra spacing before alphabetic groups and head-
ings.

Markup tags you define for making tagged text documents can now con-
tain encoded unprintable characters.

A new Preferences… setting lets you control whether entries embedded in 
other documents carry special sorting information.

Sorting Entries

There is a change in the way Cindex sorts text within parentheses. For-
merly, in a letter-by-letter or word-by-word sort Cindex either treated the 
parenthetical text as a continuation of the text preceding the opening 
parenthesis, or ignored it altogether if you had checked Ignore Text in Parenthe-
ses. Cindex now distinguishes two kinds of text in parentheses:

• A parenthetical phrase qualifying a preceding term. Cindex now sorts 
the heading so that it immediately follows any otherwise identical 
heading that lacks the qualifying phrase. The text in parentheses is 
ignored unless it is the only text that distinguishes headings.

• A parenthetical ending to a word, such as cat(s). This is handled as 
before, according to the setting (now renamed) of Ignore Parenthetical End-
ings.

In addition to the letter-by-letter and word-by-word alphabetizing options 
formerly available, Cindex now provides preset collections of settings for 
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two standard alphabetizing rules: those recommended by the 15th edition 
of the Chicago Manual of Style, and those recommended by ISO 999.

Cindex provides improved sorting of locators.

• Sometimes a text style (bold, italic, underline) is used to distinguish dif-
ferent types of references to the same page. You can now assign a prece-
dence to different text styles (Style Precedence under the Locators tab). 
Cindex uses the setting when the text style is the only attribute that dis-
tinguishes two page references (or the least significant parts of multi-
part references).

• If you are working with compound (multi-part) locators Cindex nor-
mally evaluates the different segments in the order specified by your 
setting of Segment Order under the Locators tab. If locators contain more 
than 10 distinct segments, Cindex ignores this setting and evaluates the 
segments serially, from first to last.

Checking References

The former Verify Cross-References… command (renamed Check References…) has 
additional capabilities. With or without also verifying cross references you 
can now find entries that contain more than a specified number of page ref-
erences. Cindex will display (in the form used to show bad or questionable 
cross-references) the entries that contain too many unqualified page refer-
ences.

Managing Cross-References

The former Generate Cross-References command (renamed Manage Cross-Refer-
ences…) has additional capabilities. Cindex can now automatically convert 
See cross-references to fully qualified entries when the See references have 
fewer than a specified minimum number of target entries.

Reconciling Headings

The Reconcile Headings… command has extended capabilities. You can use it to 
find and display entries that contain orphaned subheadings as well as to 
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identify and correct entries in which headings and subheadings should be 
rationalized.

Getting Information about Indexes

When you use Count Records… or Index Statistics… to examine records in the 
fully-formatted view, Cindex attends to the setting of Hide by Attributes…, and 
examines only those records that would be visible in that view.

When you use Count Records…Cindex now provides separate counts of 
records with different labels.

When you use Index Statistics… Cindex now provides a count of the number 
of unique main headings.

Abbreviations

When you enter or edit abbreviations in the Abbreviations window, Cin-
dex now provides unlimited undo and redo.

The top of the abbreviation window now contains a bar with column head-
ers that control how abbreviations are sorted for display. You can view the 
display sorted by abbreviation or sorted by expansion: click the relevant 
header above the abbreviations or expanded phrases.
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