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CINDEX 2.0 for Mac Release Notes

                
CINDEX 2.0 for Mac
This document explains how CINDEX™ 2.0 for Mac differs from CIN-
DEX™ for OS X.

You should read this document if you are upgrading from CINDEX for 
OS X. You do not need to read this document if you are a new user of CIN-
DEX.

CINDEX 2.0 for Mac works very much like CINDEX for OS X. If you are 
familiar with CINDEX for OS X you should have no difficulty mastering 
CINDEX 2.0 for Mac.

Overview of New Features

User Experience Cindex is generally faster, and provides major new editing capabilities 
including an exceptional ‘smart’ flip, and better checks for well-formed 
entries. The layout of many panels has been improved.

When See cross-references refer to fewer than a specified minimum num-
ber of target entries, Cindex can automatically convert them to fully-quali-
fied entries.

Managing Index Files Cindex routinely checks the integrity of indexes, and can repair records if 
they are ever damaged. A new Revert to Saved command restores the index to 
its last-saved state—useful if you have made some major changes to the 
index that you then decide to discard. 



                             
Managing Multi-Purpose 
Indexes

An index record can now contain a special field for holding a comment or a 
web address, etc. You can use multiple labels to control the visibility of dif-
ferent kinds of index records.

Formatting Entries Headings and subheadings can be preceded by optional prefix text. You 
can override the standard index style on an entry-by-entry basis. There are 
new options for placing cross-references and for punctuating them auto-
matically.

Sorting Entries New capabilities include better handling of text in parentheses, preset 
options for Chicago Manual of Style or ISO 999 alphabetizing, and more 
refined sorting of locators.

Exporting Entries Cindex can now export a fully formatted index as tagged text for Adobe 
InDesign. When you embed entries in other documents you can now con-
trol whether sorting information is also embedded.

System Requirements

Cindex 2.0 works with Mac OS 10.4 or higher. It will not run under any ear-
lier version of OS X.

Compatibility

Cindex 2.0 can work with all documents made with Cindex for OS X, but 
note the following:

When you open an index (.ndxf) file made by Cindex for OS X, Cindex will 
make a new index document from it (with filename extension .cdxf). Cin-
dex will preserve the old index, and will add a suffix “[V1 index]” to its 
name, leaving it otherwise untouched.

Because of a change in the way in which groups are managed, Cindex 2.0 
will delete any groups that belong to the newly converted index.
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Cindex 2.0 indexes cannot be opened by Cindex for OS X. If you want to 
open a Cindex 2.0 index in Cindex for OS X, make an archive. Archives can 
be used interchangeably among all versions of Cindex.

Menu Commands

New Commands There are three new commands:

• A Revert to Saved command in the File menu. This restores the index to its 
last-saved state (see “Document Management” on page 4).

• A new Hide by Attributes command in the View menu (see “Viewing the 
Index” on page 6).

• A Check for Update command in the Cindex menu.

Commands Changed • The Labeled command (Edit menu) now contains a submenu that pro-
vides additional labeling options. See “Record Attributes and Struc-
ture” on page 5.
There are new keyboard shortcuts for labeling records. The shortcut for-
merly used to label/unlabel records (COMMAND =) will apply/remove 
label 1 only. This shortcut is not visible in any menu item.

• Generate Cross-References… (Tools menu) has been extended and renamed 
Manage Cross-References… See “Managing Cross-References” on page 9.

Toolbars

Toolbar buttons for flipping record fields have changed functions. See 
“Adding and Editing Records” on page 5.

Some toolbar buttons in the record-entry window now have keyboard 
shortcuts. The shortcuts are identified in the tooltips associated with the 
toolbar buttons.
    3



                                    
Document Management

Cindex checks the integrity of an index each time the index is opened. If 
Cindex detects any errors or damage, it will alert you and recommend that 
you let it repair the index.

Cindex now provides a Revert to Saved command in the File menu. This 
restores the index to its last-saved state. You might wish to do this if you 
have made some major changes to the index that you then decide to dis-
card. Cindex updates the saved copy automatically at regular intervals if 
you have specified this via Preferences…. Cindex also updates the saved 
copy when you choose Save from the File menu.

Exporting Documents When you export index records in tab-delimited format you can now spec-
ify (via Options in the Save Panel) a minimum number of fields that Cindex 
should save. If a record contains fewer than this minimum number, Cindex 
writes empty fields between the last subheading field and the locator field.

Cindex can now export formatted indexes as tagged text documents for 
Adobe InDesign.

Preferences

Several new settings made via Preferences… provide you more flexible con-
trol of Cindex:

• Under the General tab you can set Cindex so that it automatically noti-
fies you if an update is available. (You can also check for updates at any 
time by choosing Check for Update from the Cindex menu).

• Under the Editing tab you can specify whether Cindex does a 'smart' or 
literal flip when you exchange the contents of two record fields.

• Under the View tab you can specify the colors of 7 different labels that 
Cindex can attach to records. To change a label color, click the corre-
sponding color well.

• Under the Export tab you can specify whether entries embedded in 
other documents carry special sorting information.
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Record Attributes and Structure

A record may now have one of seven different labels, identified by text dis-
played in a distinctive color. To accommodate this change, the Labeled com-
mand now exposes a submenu, and the Label toolbar button now carries a 
drop-down list. There are corresponding changes in the Find and Replace 
panels, so that you can search for records that have a specified label. 
Expanded Preferences… settings (under the View tab) allow you to assign a 
different color to each label. The keyboard shortcut formerly used for label-
ing and unlabeling records (COMMAND =) works, as before, to apply and 
remove Label 1 only. This shortcut is not visible in any menu item, and has 
no effect on records that carry other labels.

You can now specify (via Record Structure in the Document menu) that a 
record must always contain a special subheading field that you can use to 
store a comment or a URL, etc. At your option Cindex can ignore this field 
when sorting records and can hide it when it displays a formatted index. 
This special field, when present, is always the one immediately preceding 
the locator field.

In an index that already contains records you can now change (via Record 
Structure in the Document menu) the minimum number of record fields.

There is a new setting under Reference Syntax… (Document menu) to control 
whether Cindex recognizes cross-references entered as subheadings. The 
default (for new indexes) is to recognize cross-references only in the locator 
field.

Adding and Editing Records

The editor used when you make and modify records is improved:

• If you hold down the SHIFT key while you paste or drag text into the 
record window, Cindex will insert only plain text (discarding informa-
tion about style and font).

• In addition to the warnings Cindex provides for mismatched {…} and 
(…), Cindex will warn you when you enter mismatched "…" or mis-
matched smart quotes (“…”).
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• You can half-flip (promote) a subheading to a heading (discarding the 
heading at the level above). The shortcut for a half-flip (CTRL –) is the 
one previously used to flip headings without changing the case of initial 
letters. 
A flip can be 'smart' at the user's option. In a smart flip Cindex adjusts 
the case of leading letters, and moves prepositions and articles, or the 
prefatory text to see also cross-references, if necessary. A new Preferences… 
setting (Editing tab) determines whether Cindex executes smart flips.

• When you attempt to enter a record that is incomplete or badly con-
structed (e.g., contains mismatched angle brackets <…>), Cindex now 
displays information about the error in the status bar at the foot of the 
entry window.

• When you use a function key to insert text in a particular font or style, 
Cindex no longer carries the style and font of the inserted text to charac-
ters you subsequently type.

• The text of a labeled record is displayed in the color assigned to the 
label. To accommodate this change, text set in small caps is now 
denoted by normal text with a light gray background behind it.

• When you revert a record to its initial state, Cindex now restores the 
original deleted and labeled status. Formerly only the text reverted to 
the original.

Viewing the Index

When you seek a record by typing its number or leading text in the main 
index view, Cindex displays the text in a small box at the foot of the win-
dow. This is colored red if no record matches the search specification.

When records are selected in the main window, you can extend the selec-
tion via the keyboard by holding the SHIFT key down while hitting the UP-
ARROW or DOWN-ARROW key. If you select records by clicking and dragging 
in the main view, you can now continuously extend the selection and scroll 
the display by dragging off the bottom or the top of the view.

Because a record can now carry one of seven different labels there is a 
change in the way Cindex uses color to identify a labeled record in the fully 
formatted view of the index. Only the locators (page references or cross-
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references) that belong to the labeled record are colored, unless the locator 
field has no text, in which case the last visible subheading is colored.

You can use labels to control the visibility or records. The new command 
Hide by Attribute… (View menu) allows you to hide records containing partic-
ular labels (or none). Records that are hidden are invisible to all commands 
that act globally on the index, except Compress and Expand, which ignore the 
Hide by Attribute… setting.

Find, Replace, and Spelling

When you are working with a fully formatted view of the index, Find, Replace 
and Spelling are sensitive to the setting of Hide by Attribute….

Find and Replace provide new options for searching among records:

• As in earlier versions of Cindex, you can confine a search to records that 
have particular attributes (New, Modified, Deleted, etc.), but you can 
now also confine a search to records that lack particular attributes.

• When you specify that the search involves labeled records you can now 
specify a particular label.

• You can specify dates more flexibly, and you can include a time with the 
date. If you specify a date but no time, Cindex assumes the time to be 
noon. If you omit the date (specifying only a time), Cindex assumes 
today. You can use simple English expressions as shortcuts, for example: 
today (12:00 a.m. today); noon (12:00 p.m.); tomorrow (12:00 a.m. 
tomorow). To find all records made yesterday or today, you could enter 
yesterday as the starting date and tomorrow as the ending date.

User dictionaries for Spelling can now hold many more entries (~6,600).

Formatting Entries

In the fully formatted view Cindex can now provide prefix text immedi-
ately before the text of any level of heading. Set this via Headings… in the 
Document menu.
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In a fully formatted index that is displayed indented, you can override the 
default layout of individual entries by including special text in records. If 
the last character of any heading or subheading is a vertical bar (|), Cindex 
will run-on all lower levels of heading for that entry. Cindex automatically 
substitutes the appropriate leading punctuation for the bar as it formats 
the entry.

Cindex provides (via Cross-References… in the Document menu) new options 
for placing and punctuating cross-references:

• Cindex can place see also references after all subheadings, except when 
there are no subheadings, in which case the cross-references directly fol-
low the page references from the heading.

• Cindex can now automatically capitalize the first word of the prefatory 
phrase (e.g., "see…" or "See…") according to the placement and punctu-
ation of the cross-reference.

Exporting Formatted 
Entries

Cindex can now export a fully formatted index as tagged text for Adobe 
InDesign.

Cindex now provides a richer export for QuarkXPress tagged text, includ-
ing information about extra spacing before alphabetic groups and head-
ings.

Markup tags you define for making tagged text documents can now con-
tain encoded unprintable characters.

A new Preferences… setting lets you control whether entries embedded in 
other documents carry special sorting information.

Sorting Entries

There is a change in the way Cindex sorts text within parentheses. For-
merly, in a letter-by-letter or word-by-word sort Cindex either treated the 
parenthetical text as a continuation of the text preceding the opening 
parenthesis, or ignored it altogether if you had checked Ignore Text in Parenthe-
ses. Cindex now distinguishes two kinds of text in parentheses:
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• A parenthetical phrase qualifying a preceding term. Cindex now sorts 
the heading so that it immediately follows any otherwise identical 
heading that lacks the qualifying phrase. The text in parentheses is 
ignored unless it is the only text that distinguishes headings.

• A parenthetical ending to a word, such as cat(s). This is handled as 
before, according to the setting (now renamed) of Ignore Parenthetical End-
ings.

In addition to the letter-by-letter and word-by-word alphabetizing options 
formerly available, Cindex now provides preset collections of settings for 
two standard alphabetizing rules: those recommended by the 15th edition 
of the Chicago Manual of Style, and those recommended by ISO 999.

Cindex provides improved sorting of locators.

• Sometimes a text style (bold, italic, underline) is used to distinguish dif-
ferent types of references to the same page. You can now assign a prece-
dence to different text styles (Style Precedence under the Locators tab). 
Cindex uses the setting when the text style is the only attribute that dis-
tinguishes two page references (or the least significant parts of multi-
part references).

• If you are working with compound (multi-part) locators Cindex nor-
mally evaluates the different segments in the order specified by your 
setting of Segment Order under the Locators tab. If locators contain more 
than 10 distinct segments, Cindex ignores this setting and evaluates the 
segments serially, from first to last.

Managing Cross-References

The former Generate Cross-References command (renamed Manage Cross-Refer-
ences…) has additional capabilities. Cindex can now automatically convert 
See cross-references to fully qualified entries when the See references have 
fewer than a specified minimum number of target entries.

Compressing the Index

When you consolidate references from records containing identical head-
ings and subheadings, you can choose whether to consolidate references 
from records that carry different labels.
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Reconciling Headings

The Reconcile Headings… panel has been reorganized to make its functions 
clearer. You can use it to find and display entries that contain orphaned 
subheadings as well as to identify and correct entries in which headings 
and subheadings should be rationalized.

Getting Information about Indexes

When you use Count Records… or Index Statistics… to examine records in the 
fully-formatted view, Cindex attends to the setting of Hide by Attributes…, and 
examines only those records that would be visible in that view.

When you use Count Records…Cindex now provides separate counts of 
records with different labels.

When you use Index Statistics… Cindex now provides a count of the number 
of unique main headings.

Abbreviations

You can now print the active set of abbreviations with their expanded 
phrases.
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